Ruby 1.8.7 Breaks Radiant

Posted by Sean Cribbs on Wednesday, June 18, 2008 | |

We’ve received several reports that Ruby 1.8.7, which includes backports of functionality from the 1.9 branch breaks Radiant, primarily with respect to the Enumerator class. Please use Ruby 1.8.6 or earlier until we can resolve this issue. Contributed patches that resolve the issues while maintaining backward-compatibility with 1.8.6 and earlier would be appreciated.